package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{2}[\.]?[0-9]{3}[\.]?[0-9]{3}[\/]?[0-9]{4}[-]?[0-9]{2})|([0-9]{3}[\.]?[0-9]{3}[\.]?[0-9]{3}[-]?[0-9]{2})`)
var str = `CPF 11111111111
CNPJ11.111.111/0001-11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}