re = /"S":"(?<S>.*?)".*"IMEI":"(?<IMEI>.*?)".*/m
str = '{"ID":"NOKIA-71E1","KY":"59ad728d99","U":"admin","P":"cfa522ec5a","S":"FSH21290288A","23S":"DC8D8A4171E1","N":"5G12-13W-A","PN":"3TG00799ABAA","IMEI":"352778340662308"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end