package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(xcopy)|([A-Z]:\\[^ ]*)+`)
var str = `xcopy C:\test D:\target\backup\files
(xcopy)|([A-Z]:\\[^ ]*)+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}