re = /^[1-9]\d{7}((0\d)|(1[0-2]))(([0|1|2]\d)|3[0-1])\d{3}$/
str = 'zhuzhi.asf@mail.us'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end