const regex = /v6\/[0-9]{3}[a-z]?\/(?!(elodie|bacchus|sophie)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('v6\\\/[0-9]{3}[a-z]?\\\/(?!(elodie|bacchus|sophie)).*$', 'gm')
const str = `v6/429/elodie
v6/429/bacchus
v6/429/Bacchus
v6/429/Bac chus
v6/429/truc
v6/429/sophie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}