use strict;
my $str = ' esto es algo que tiene muchos espacios al pedo ';
my $regex = qr/^\s+|\s+$|(\s)\s+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";