const regex = new RegExp('(^\\d{4}-\\d{2}-\\d{2} \\d{1,2}:\\d{2}:\\d{2},\\d{3}) (FATAL|ERROR|WARN|INFO|DEBUG) \\[(\\S*)\\] \\[(\\S*)\\] (\\S*) - (.*)', 'gm')
const str = `2023-02-10 09:51:45,247 INFO [NotFromActor] [main] com.thatdot.quine.app.Main\$ - Running 1.5.1 with 10 available cores and 12GiB max heap size.
2023-02-10 09:51:45,897 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-4] com.thatdot.quine.persistor.ExceptionWrappingPersistenceAgent - No version was set in the persistence backend for: core quine data, initializing to: Version(13.0.0)
2023-02-10 09:51:45,992 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-4] com.thatdot.quine.graph.GraphService - Adding a new local shard at idx: 0
2023-02-10 09:51:45,994 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-4] com.thatdot.quine.graph.GraphService - Adding a new local shard at idx: 1
2023-02-10 09:51:45,994 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-4] com.thatdot.quine.graph.GraphService - Adding a new local shard at idx: 2
2023-02-10 09:51:45,994 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-4] com.thatdot.quine.graph.GraphService - Adding a new local shard at idx: 3
2023-02-10 09:51:46,004 INFO [NotFromActor] [graph-service-akka.actor.default-dispatcher-15] com.thatdot.quine.persistor.ExceptionWrappingPersistenceAgent - No version was set in the persistence backend for: Quine app state, initializing to: Version(1.1.0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}