use strict;
my $str = 'https://firebasestorage.googleapis.com/v0/b/geographical-memories-dev.appspot.com/o/Fa4NPIoM5sON70uDJjufgnL5DHY2/01792dcc-4963-4658-a3d0-99073b352e22?alt=media&token=23676a66-ed8d-4b43-9150-6ef3f07544f0
https://firebasestorage.googleapis.com/v0/b/geographical-memories-dev.appspot.com/o/Fa4NPIoM5sON70uDJjufgnL5DHY2/01792dcc-4963-4658-a3d0-99073b352e22?alt=media&token=80a5cc0f-7943-4ef8-ab00-9bef8acd41bf';
my $regex = qr/\/o\/([a-zA-Z0-9]+)\/([a-zA-Z0-9-]+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}