package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)foo.*!`)
var str = `foo
1
2
3
bar
!
!
2
3
bar
!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}