const regex = /(?<!^)|(?<! )(?<!-)N(?=[a-z])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^)|(?<! )(?<!-)N(?=[a-z])', '')
const str = `Noquevocêe N-NANIKONOSUBANstápenNsando?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}