# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(curl (-.*)?(\S+)?(https?:\S+|www\.\S+|ftp:\S+(.*)))"
test_str = ("curl -o output.txt http://example.com\n"
"curl https://httpstat.us/400 -f\n"
"curl http://executable.sh | bash\n"
"curl ftp://executable.sh | sudo bash\n"
"curl www.helloworld.com > test.file\n"
"curl -X 'GET' 'http://localhost:8000' -H 'accept: application/json'\n\n"
"curl -s https://packagecloud.io/install/repositories/github/git-lfs/script.deb.sh | bash\n"
"curl -X 'GET' 'http://localhost:8000' -H 'application/json'\n"
"curl -X 'GET' \"http://localhost:8000\" -H 'application/json'\n"
"RUN curl --user \"APITest:API.User\" https://secure.example.com/api/REST/1.0/data/contacts?count=2\n"
"curl --header \"Content-Type: application/json\" -d '{\"emailAddress\":\"george.washington@america.com\"}' https://secure.example.com/api/REST/1.0/data/contact\n"
"curl -X GET -H \"Authorization: Bearer {ACCESS_TOKEN}\" \"https://api.server.io/posts\"\n"
"curl --user \"<companyName>:<userName>\" --request GET https://secure.p0<podNumber>.eloqua.com/api/<apiType>/<apiVersion>/<endpoint>\n"
"curl --user \"APITest:API.User\" --header \"Content-Type: application/json\" --request POST --data '{\"emailAddress\":\"george.washington@america.com\"}' https://secure.example.com/api/REST/1.0/data/contact\n"
"curl --user \"APITest:API.User\" --header \"Content-Type: application/json\" --request PUT --data '{\"id\":\"1\",\"emailAddress\":\"george.washington@america.com\",\"businessPhone\":\"555-555-5555\"}' https://secure.example.com/api/REST/1.0/data/contact/1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.