re = /[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*@((?!-)[A-Za-z0-9-]{0,62}[A-Za-z0-9]\.)+(edu|gov)/
str = 'test@lapu.co.uk.edu
test@gov
me@a.mil.gov'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end