package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)fwrite\((.*)\)\;??`)
var str = `fwrite($fp, "(TOP $msgNum $numLines\r\n)");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}