$re = '/(\|)*[\s]*\d{1,2}\/\d{1,2}\/\d{4}/';
$str = '6/29/2014 Thanks Elizabeth, I cannot afford those prices without the groupon, as I have been unemployed for over one year. If prices go down, or groupon offered, please let me know. | Maggie | | 6/26/2014 We checked your paperwork and you had 3 treatments for your lip and 3 treatments for your chin both done on groupon. We do not do groupons anymore so the current pricing for those areas are as follows | | Lip | Single treatment - 99 | 3 treat - 187.50 | 6 treat - 375 | 9 treat - 450 | | Chin | Single Treatment -101 | 3 treat - 201 | 6 treat - 402 | 9 treat - 482 | | I hope this was helpful | | 6/25/2014 Margaret lm on rc - she did not say why she was calling - lm for her that she was in our system and that it looked like she came for a groupon on the lip or chin, which we dont offer anymoer, but if she would like to call on Thursday we would pull her paperwork in Allentown -eliz | 8/28/2012 sw-eliz | 7/11/2012 She said that she lm 7/9 and sent email to cancel but did not hear back, I canceled 7/11 for her 7/13 appt. no fee-mb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);