use strict;
my $str = '"text":"Perspektivtegning: Samlede skabe til køkken 13207/1/1 Alternativ - 1"
"text":"Perspektivtegning: køkken 13207/1/1 Alternativ - 1"
"text":"Opstalt: Entré 30811/3/1 Alternativ"
"text":"Opstalt: Entre 30811/3/1 Alternativ"
"text":"Opstalt: Nyborggade 2.4.sal 13767/2/2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767-2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2 1Alternativ"
"text":"Opstalt: Nyborggade 2 13767-2 1Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2-2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767-2/2 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/2 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767-2/2 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2-2 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/99/2 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/99 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/2 11 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/22/22 11 Alternativ"
"text":"Opstalt: Nyborggade 2 13767-2-2 1 Alternativ"
"text":"Opstalt: Nyborggade 2 13767/2/2 1 Alternativ"
"Text":"ojasdj: 151-2901-620 f"
"Text":"Date: 20-11-2022 "';
my $regex = qr/\d{3,15}[\/-]{1}\d{1,2}([\/-\s]{1}\d{1,2}|)(\s+\d{0,2}|)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}