// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|\s)(#\w+)").unwrap();
let string = "Hello this is helloworld#helloworld
Hello this is Helloworld #helloworld #hiworld #nihaoworld ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}