import re
regex = re.compile(r"\/car-finance\/home\/(.*)\?t=(.*)&w=1", flags=re.MULTILINE)
test_str = "/car-finance/home/3f737e9c-dd36-4995-998e-eb33cdfec70f?t=SE[…]Hc+wXfuf7ZyyszX2p/i4OpnuU3buTHAu3DYDpbr53h8s2gC+IgDxvVsijVs&w=1"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")