import re
regex = re.compile(r"(?<=^CN=)(.*?)(?=\s?,\s?o)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("CN= John Q. Public, O=Agency, C=US\n"
"CN= John Q. Public, Jr.,O=Agency, C=US\n"
"CN=John Q. Public,O=Agency, C=US\n"
"CN=John Q. Pu,blic,O=Agency, C=US\n"
"CN=some name,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
"CN=some name, ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
"CN=some name-Y- , ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
"cn= some name-Y-,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n"
"cn= some na, o me-Y-,ou=Groups,ou=AAA,ou=DCCOMICS,o=boo berries,c=US\n\n"
"(?<=^CN=) - positive lookahead to find string starts with CN= and discard that match\n"
"(.*?) - non greedy seach for any single character\n"
"(?=,\\s?ou\\s=|,\\s?o\\s?=)\n\n\n"
"(?=,\\s?ou\\s=|,\\s?o\\s?=)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")