$re = '/\d{2}(?|(-{3})|(-)|(.)|(:))\d{2}\1\d{2}\1\d{2}/m';
$str = '12-34-56-78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);