$re = '/[а-я]{4,}/m';
$str = 'организация охраны 21 617';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);