$re = '/(?:<(a|img)(?:\s[^>]*)*>)((?:(?!<\1).)*)(?:<\/\1>)/m';
$str = '
<img>content</img> <img src="some-pic-url">content</img>
<a> content </a> <a href="url">content</a>
<a href="url">content</img>
<img src="some-pic-url">content</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);