$re = '/(?<Myid>[a-zA-Z0-9-]+[^-]{1})/m';
$str = 'abc-ยง';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);