$re = '/page\/|page\/\d/';
$str = '/page/
/page/2
kartinki/page/
kartinki/page/4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;