re = /\/@?(\w+)(?=[^\/]*$)/m
str = 'https://www.twitter.com/sachin
https://www.twitter.com/@sachin
https://www.twitter.com/@sachin
https://www.twitter.com/sachin?lang=en'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end