#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(\s|^)[\u0400-\u04FF]{2,5}(\s|[.,])"
Local $sString = "1. Я проходил службу вв мвд. в ханкале с 2002 по 2003 год, 19 дней мне закрыли боевых, в воеенике все записи есть, получил удостоверение ветерана боевых действий. После потере удостоверения я обратился в мвд архив по месту жительства и полученя удостоверения, мне сказали что мы отправим запрос в Москву главный архив и они примут решение выдавать мне удостоверение или нет, говорят многим было отказано. Вопрос получу я или нет? 1.1. Вы получаете не удостоверение а дубликат, и здесь технический вопрос а не вопрос принятия решения. 2. Как мне найти справку о 1)смерти или 2) хотя бы рождении моего прадеда, если я знаю о нем только ФИО и все, не знаю где умер и жил последние годы жизни. Данная справка мне нужна для принятия наследства в судебном порядке. Делала запрос на розыск человека в МВД, ЗАГС, архив своего города- но данных на такого человека у них нет. 2.1. Анастасия Добрый день. На какое имущество Вы хотите вступить в наследство после смерти прадеда. 3. Пишу сразу на звонки не разводить."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")