$re = '/^[0-9\-%]+$/m';
$str = '15%-10%-1%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);