package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{1}`)
var str = `goo A greAS gir PE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}