re = /(http|https|ftp|ftps)\:\/\/www\.([a-zA-Z0-9]{5})\.com(\w*\/\S*)?/
str = 'http://www.abcde.com/index.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end