import re
regex = re.compile(r"#(?P<_id>[0-9]+) @ (?P<left>[0-9]+),(?P<top>[0-9]+): (?P<width>[0-9]+)x(?P<height>[0-9]+)", flags=re.MULTILINE)
test_str = ("#1 @ 1,3: 4x4\n"
"#2 @ 3,1: 4x4\n"
"#3 @ 5,5: 2x2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")