$re = '/(^|\W)test($|\W)/m';
$str = 'test
a-test-here
some test
a_test_here
atest-here
atesthere';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);