re = /(?s)#\sshow\s*(.*?)version\s*([\d.]+)/
str = 'wgb-car1# show startup-config
Using 6149 out of 32768 bytes
!
! NVRAM config last updated at 15:50:05 UTC Wed Oct 1 2014 by user
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end