re = /(?!1\.2)([0-9]\.[0-9]\.[0-9])/m
str = '<Tag Id1="1.1.1-text" Id2="1.1.2-text" Id3="1.2.3-text" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end