#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s:\A.*?^keyword1|^keyword2.*)(*SKIP)(*F)|^.*?(?=\h---)"
Local $sString = "badstring ---" & @CRLF & _
"useless data" & @CRLF & _
"keyword1 ---" & @CRLF & _
"usless data" & @CRLF & _
"string 1 ---" & @CRLF & _
"random number of useless lines of characters across newlines" & @CRLF & _
"string 2 ---" & @CRLF & _
"more useless stuff" & @CRLF & _
"keyword2 ---" & @CRLF & _
"useless data" & @CRLF & _
"dumb badstring keyword2 ---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")