$re = '/^[^-]*\K-([^:]+)/m';
$str = 'GW-date45:ger-date45:mySAPgives
DC-date48ccc:date48:mySAP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);