use strict;
my $str = 'disk = [\'file:/OVS/Repositories/0004fb0000030000c83b5c9f7ae78c70/VirtualDisks/0004fb00001200009ddb6b8cbb9a3ad2.img,xvda,w\', \'phy:/dev/mapper/3624a9370ab906bd01c3f4e00000112a2,xvdb,w\', \'phy:/dev/mapper/3624a9370ab906bd01c3f4e0000011061,xvdc,w\', \'phy:/dev/mapper/3624a9370ab906bd01c3f4e00000110a0,xvdd,w\', \'file:/dev/mapper/3624a9370ab906bd01c3f4e000001129a,xvde,w\', \'phy:/dev/mapper/3624a9370ab906bd01c3f4e000001132c,xvdf,w\']
';
my $regex = qr/(^disk\W+\[)?('file:[^']+'(,)?)?('phy:[^']+'(,)?)?(])?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";