import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "3\\d{4}";
final String string = "AAXX 29224 03410 26768 82603 10106 20085 39676 40104 52008 88/// 333 55300 20000 60005 88/50 91004 90710 91106\n\n"
+ "BBXX VRPY6 25204 99304 50002 41397 50713 10160 20130 40250 54000 7//00 851// 22263 00190 21004 32323 41004 51004 6//// 80140 ICE /////";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}