using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://www.filmxy.vip/movie/(tt[0-9]*)?(.*[^/])";
string input = @"https://www.filmxy.vip/movie/chupkotha/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}