import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^---\\K(?:\\R(?!---$).*)*+(?=\\R---$)";
final String string = "\n"
+ " \n\n"
+ "---\n"
+ "key: value\n"
+ "foo: bar, zip, grump\n"
+ "/*\n"
+ "Anything can go in here, once I have this section pulled out, the yaml schema\n"
+ "can do the reset. All that's important to note is that this section must be\n"
+ "terminated explicitly with a subsequent /^---\\s*$/ in order to be deemed valid.\n"
+ "---\n\n"
+ "Anything else can follow here, more accidental frontmatter blobs can exist,\n"
+ "but it should not matter since the other requirement is that the regex engine\n"
+ "will cease processing beyond the termination of the first match.\n\n\n"
+ " \n\n"
+ "---\n"
+ "key: value\n"
+ "foo: bar, zip, grump\n"
+ "/*\n"
+ "Anything can go in here, once I have this section pulled out, the yaml schema\n"
+ "can do the reset. All that's important to note is that this section must be\n"
+ "terminated explicitly with a subsequent /^---\\s*$/ in order to be deemed valid.\n"
+ "---\n\n"
+ "Anything else can follow here, more accidental frontmatter blobs can exist,\n"
+ "but it should not matter since the other requirement is that the regex engine\n"
+ "will cease processing beyond the termination of the first match.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}