package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?([78]+)\d{10}$`)
var str = `/*
Могут поступить номера
+79095876084
79095876084
89095876084
*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}