$re = '/[A-z]+(:?\(\d+\))*/m';
$str = 'foo(1)(1)
foo(1)(2)
foo(1)(3)(3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);