import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<HostName>(?<=\\),).*?(?=,.?Default))";
final String string = "\"2018-12-12 13:25:30\",\"Renju, Jacob,M(renjutest)\",\"Renju, Jacob, M (rtest),Renju123,Default Site,Test/firewall\",\"10.221.5.136\",\"XXX.XXX.XXX.XXX\",\"Allowed\",\"16 (A)\",\"NOERROR\",\"1XX.1X.1XX.1XX.Test.com.\",\"Computer Security\"\n\n\n"
+ "\"2018-12-12 13:09:55\",\"rtest\",\"Renju123,Default Site,Renju Renju/Renju\",\"10.250.33.85\",\"XXX.XXX.XXX.XXX\",\"Allowed\",\"12 (PTR)\",\"NOERROR\",\"1XX.1X.1XX.1XX.Test.com.\",\"Software/Technology\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}