// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""service"\s*:\s*{\s*"healthy"\s*:\s*true"#).unwrap();
let string = "{
\"service\": {
\"healthy\": true
},
\"cassandra_connection\" : {
\"healthy\" : true
},
\"deadlocks\" : {
\"healthy\" : true
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}