// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^wp-includes\/.*\.php$").unwrap();
let string = "wp-includes/ID3/module.audio.ac3.php
wp-includes/test/something.css
wp-includes/somephpfile.php";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}