# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?im)\b(?:https?:\/\/)?(?:w{3}\.)?youtu(?:be)?\.(?:com|be)\/(?:(?:\??v=?i?=?\/?)|watch\?vi?=|watch\?.*?&v=|embed\/|)([A-Z0-9_-]{11})\S*(?=\s|$)"
test_str = ("http://youtube.com/v/tFad5gHoBjY\n"
"https://youtube.com/vi/tFad5gHoBjY\n"
"http://www.youtube.com/?v=tFad5gHoBjY\n"
"http://www.youtube.com/?vi=tFad5gHoBjY\n"
"https://www.youtube.com/watch?v=tFad5gHoBjY\n"
"youtube.com/watch?vi=tFad5gHoBjY\n"
"youtu.be/tFad5gHoBjY\n"
"http://youtu.be/qokEYBNWA_0?t=30m26s\n"
"youtube.com/v/7HCZvhRAk-M\n"
"youtube.com/vi/7HCZvhRAk-M\n"
"youtube.com/?v=7HCZvhRAk-M\n"
"youtube.com/?vi=7HCZvhRAk-M\n"
"youtube.com/watch?v=7HCZvhRAk-M\n"
"youtube.com/watch?vi=7HCZvhRAk-M\n"
"youtu.be/7HCZvhRAk-M\n"
"youtube.com/embed/7HCZvhRAk-M\n"
"http://youtube.com/v/7HCZvhRAk-M\n"
"http://www.youtube.com/v/7HCZvhRAk-M\n"
"https://www.youtube.com/v/7HCZvhRAk-M\n"
"youtube.com/watch?v=7HCZvhRAk-M&wtv=wtv\n"
"http://www.youtube.com/watch?dev=inprogress&v=7HCZvhRAk-M&feature=related\n"
"youtube.com/watch?v=7HCZvhRAk-M\n"
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.