using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+.ACT\w+),?.*";
string input = @"FormAttachments.ACT_RequiredImages_Load
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus,WorkOrder.ACT_ShowMaintHome_FromLoading
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}