re = /(?:\G(?!\A)|\[)[a-zA-Z.]*\K(?:(А)|(а)|(І)|(і)|(В)|(С)|(с)|(Е)|(е)|(Р)|(Т)|(т)|(О)|(о)|(К)|(к)|(Х)|(х)|(М))(?=[[:alpha:].]*])/m
str = '[Root.GetSomething] [Rооt.GеtSоmеthіng]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end