$re = '/^(?=(.)*$).*?\1/m';
$str = 'character
test
no match
This is a test
I came. I saw. I conquered.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);