$re = '/^\d{3}-\d{4}$/m';
$str = '123-4444444
123-4444
123-123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);