#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[quotemsg data-username=\"(.*?)\"\](.*?)\[/quotemsg\]"
Local $sString = "[quotemsg data-username="Александр З"]Здравствуйте, Подскажите как можно в исходном коде статей расставить классы для заголовков H2? Статей много - вручную не вариант. По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс. Например классы header1, header2, header13 Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)