const regex = /^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!([a-zA-Z0-9@._\\-\\\/,]).*\\2.*\\2).)*$', 'gmi')
const str = `This is a test
This isss a test
A testtt this is
Asassasasasas
Okay
Now no character is
allowed to appear
more
than two times
Nuevavv01
Aadsa01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}